Conclusion of libxml2 Issues – Use PHP 5.2.9 & libxml2 2.7.3

Updates
17 Mar 2009 @ 3:05pm : WordPress & libxml2 Episode IV: A New Plugin

With the release of PHP 5.2.9 all of the pieces are available to solve the XML bracket stripping puzzle. To make it perfectly clear, you need to have BOTH libxml2 version 2.7.3 and PHP version 5.2.9 in order to make this work. Mixing either one with older versions will not work. When testing this also confirm that your build of PHP 5.2.9 is using the correct version of libxml2 and not some older version (you can easily check this using phpinfo( ) ).

I went back to my test setup and built PHP 5.2.9 with libxml2 2.7.3 and added new posts to a WordPress blog via XML-RPC with lots of tags in the post body. They all came through intact. Not a single bracket missing.

If you are on a host that is using known broken version combinations of PHP & libxml2 now you can tell them exactly which versions do work. Feel free to point them this and previous posts (Problems With libxml2 For WordPress XML-RPC Users and Update On libxml2 Issues) if they want some history and context of the problem.

25 thoughts on “Conclusion of libxml2 Issues – Use PHP 5.2.9 & libxml2 2.7.3”

  1. I uploaded a phpinfo file to my server which shows libxml2 2.7.3

    Is there some other way I should verify that it is using 2.7.3?

  2. Hmm, those are the obvious things that might have gone wrong.

    You can try the work around plugin – http://josephscott.org/archives/2009/03/wordpress-libxml2-episode-iv-a-new-plugin/ – but you’ll probably need to tweak it to recognize libxml2 2.7.3.

    If you are using PHP 5.2.9 built with libxml2 2.7.3 then it should be working. If you phpinfo page is still up drop me a note – http://josephscott.org/contact/ – and I’ll take a look, see if anything jumps out at me.

  3. was this problem ever resolved?

    just hoping that when i upgrade my php from 5.2.8 to 5.2.9 and my libxml from 2.7.2 to 2.73 that my imported posts from RSS feeds will work again and not stop removing the “”. 🙂

  4. Is there any way for a ‘normal’ user to upgrade the version of libXML that comes with XAMPP 1.0.1, as unfortunately, they’ve included libXML 2.7.2 and I’m having this problem. I’m running OS X 10.4.11 and don’t seem to be able to compile anything on it — but I really don’t know much about this. I don’t suppose Apache Friends is going to do this any time soon? Right now neither MAMP, which recently stopped working all together, and XAMPP, are functioning properly and I do a lot of blog development.

  5. I’m not familiar enough with XAMPP to know how hard it would be to build it with a new version of libxml2. You may just have to use the plugin work and bug the XAMPP devs to use versions of PHP5 and libxml2 that aren’t broken.

  6. I experienced the problem with libxml2 Version 2.6.27 and PHP Version 5.2.9, and my host refused to do anything. I used the plug-in but I had to edit the if statement to work with my older version of libxml2. Once I did that, problem was solved.

  7. i have the already known issue with the stripped brakets using wordpress and posterous.

    i have already read your solution…

    i have installed ” libxml2 fix ” but it didn’t worked.

    then i upgraded php and libxml2 to php 5.2.12 and libxml2 2.7.6 on a fedora core 8. and still is not working.

    i am using php from 3.fc8.art from a plesk repository. (i have plesk installed)
    can be the problem with the php plesk release of php?
    how to solve?

    thanks

  8. Hoping this thread is still alive!

    Can you explain exactly what you needed to change to get the fix to work? My host is on PHP version 5.2.2 and libxml2 version 2.6.32 and have also refused to change anything and are pointing the finger of blame at WordPress…

  9. This problem began on my blog within the last 2 weeks. Hosting provider says they haven’t changed anything. They have confirmed that:

    “Currently the PHP version ‘5.2.17’ is set for your account. Also, libxml2 is installed in our server with the version 2.6.32. You can verify it in the PHP info page at http://ntresour.dot5hosting.com/test.php .”

    I have WordPress installed on my account (NTResources.com). I assume that the PHP v. 5.2.17 is newer than the 5.2.9 you recommend, but that’s an older version of libsml2. Is there any way for a mere mortal to update libxml2 or is this something that the provider must do? I’m waiting to hear from them this morning and will try the plugin if they refuse to update it, but I’d prefer to see the updates installed first.

    Thanks for any help.

    Rod

  10. Dear Joseph,

    I recently troubleshooted a website hosted at bluehost.com. And i’d like to point out that MarsEdit will work fine with PHP 5.3(single ini file ) and libxml version 2.7.6. Please do run a test yourself.

Leave a Reply

Your email address will not be published. Required fields are marked *