I’ve updated my LibXML2 Fix WordPress plugin so that the work around is enabled even if you have libxml2 2.7.3 installed but have a PHP version that is less that 5.2.9. This should fix servers who decided to update libxml2 without updating PHP.

Further details and history are at my LibXML2 Fix plugin page.

Update: Rein caught a typo in version 0.2, so make sure that you get version 0.2.2.