Looking for a new twist on SQL injection? Try BIGINT Overflow Error Based SQL Injection:

To perform these injection the mysql_error() should be echoed back to us that’s why this is error based injection. The MySQL version should be 5.5.5 or above. There can be lots of variations for these overflow injections.

Even error messages can betray you.